Fix All Tencent Gaming Buddy Errors Fix Voice Chat | Mic Not Working | Audio Issues

This is not an error faced by few but more than 10% gamers in PUBG universe. I have found a simple fix for the same.
Go to Sound Settings on your Windows. Look for App volume and device preferences under Other sound options. Make sure your TG Buddy is open in the background. If so, you will see TBG under the running Apps. Here you will see Input and Output options as Default. Just Change both to the USB devic
 Now right click on Sound Icon → Open Sound → go to Advanced options each time for Playback and Recording. Here untick all the options under Exclusive Mode. 


If you are not able to get output through speakers just make sure drivers installed. After you turn on PUBG mobile minimise it and go to your setting >> sound settings >> increase media volume.

Loading Stuck on 98% Error

This is a second most common issue which users are facing while trying to launch the App and I have come up with some of the best possible solutions for the same.

Tweak Windows Defender Settings

First, uninstall the Gaming Buddy by going to the Programs under the Control panel. Now, search for Windows Defender. Here click on Windows Defender Security Center and click on Virus and Threat Protection. Now open Configurations for protection against viruses and threats and Deactivate all the options available.
Once done, go to the downloaded (if deleted download again) Tencent gaming buddy file and click on the .exe file. Before hitting the install button click on the Browse option and delete Emulator Folder if present, create a new Emulator folder and click OK. Install the App and the issue is solved. Done!

Uninstall the Antivirus App

An antivirus App may cause trouble with the loading of codes necessary for the launching of Gaming Buddy. So, it is better to uninstall the App. You can also try to relax the scanning ability of the Anti-Virus by changing the settings of the AV App to protect peripheral data of the system.

Change App Engine

The DirectX and OpenGL have different working conditions, one needs a good CPU while other a good graphics processing unit respectively. So, I recommend you to change the engine and try relaunching the emulator, in most cases the issue is solved if it is due to engine incompatibility.

Delete Temp Folder

You can find the location of the Temp folder in the diagnosis option of the TGB. At the bottom of the diagnosis box, you will see the path. Open the Temp Folder and Delete the temporary file/s. Relaunch the TGB to check if the issue is solved.

2 comments: